The Following Feature Couldn’t Be Installed .Net Framework 3.5

Recently we have installed windows server 2016 and done the active directory installation and configuration also. Then I tried to download .Net Framework 3.5 from Microsoft site and tried to install the .Net Framework. But while installation it gave error as:

The following feature couldn’t be installed .net framework 3.5 (includes .NET 2.0 and 3.0)

Windows Server roles and features cannot be automatically installed or uninstalled via the Windows Features Control Panel.

The following feature couldn’t be installed .net framework 3.5

To install Windows Server roles and features, start Server Manager, or use the Server Manager cmdlets for Windows PowerShell.

The error looks like below.

We can not download and install .Net framework 3.5 as a standalone. We have to install it through the Server Manager.

  1. Open Server Manager and then click on Add roles and features.
  2. Then just click on Next till Features section. In the Select features page select .NET Framework 3.5 Features. Then click on Install.

This way you will be able to install .Net Framework 3.5. The same way we will be able to install .Net framework 3.5 in Windows server 2012 r2.

Related Post

How To Fix Windows 10 Error Eencountered